DNS issue
Incident Report for CTP Ethiopia Inc
Postmortem

No personal information was compromised or lost in this process.

You can always go to your profile to restrict access to your data, or remove your information from our site.

Posted Jul 29, 2020 - 15:53 EDT

Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 15:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2020 - 15:28 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 29, 2020 - 15:28 EDT
Investigating
We are experiencing a DNS configuration error. We will have it fixed soon.
Posted Jul 29, 2020 - 15:26 EDT