SSL Update
Incident Report for CTP Ethiopia Inc
Resolved
This incident has been resolved.
Posted Apr 18, 2021 - 21:14 EDT
Update
We have updated our servers and you can continue using our websites as usual.
Encountering errors? Email us at info@ctpethiopia.org.

List of services: https://tech.ctpethiopia.org/system-history/
Posted Apr 18, 2021 - 18:10 EDT
Monitoring
We are updating the SSL certificates across our servers and we are planning to do this in minimal downtime. You might encounter downtime. The downtime should be about a minute.
Posted Apr 18, 2021 - 18:05 EDT
This incident affected: CTP Support Site, CTP Mail Servers, and CTP Academy.