CTP Website System Upgrade
Incident Report for CTP Ethiopia Inc
Resolved
Upgrade Complete!
Posted Dec 09, 2020 - 21:21 EST
Investigating
We are upgrading the system; you can continue using the website as normal. We will let you know when the upgrade is done.
Follow more updates at https://crawl.ctpethiopia.org/~/sys-status/ctp
Posted Dec 09, 2020 - 21:14 EST
This incident affected: CTP Support Site and CTP Academy.